summaryrefslogtreecommitdiffstats
path: root/tsutils/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tsutils/CMakeLists.txt')
-rw-r--r--tsutils/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/tsutils/CMakeLists.txt b/tsutils/CMakeLists.txt
new file mode 100644
index 0000000..96e457c
--- /dev/null
+++ b/tsutils/CMakeLists.txt
@@ -0,0 +1,30 @@
+#
+# Copyright (c) 2018 TOYOTA MOTOR CORPORATION
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+set(TARGETS_REC tsrecorder)
+set(TARGETS_PLAY tsplayer)
+
+#add executable file
+add_executable(${TARGETS_REC}
+ tsrecorder.c tsutils.c)
+
+add_executable(${TARGETS_PLAY}
+ tsplayer.c tsutils.c)
+
+install(TARGETS ${TARGETS_REC} ${TARGETS_PLAY}
+ RUNTIME DESTINATION /usr/bin
+)
+