summaryrefslogtreecommitdiffstats
path: root/videoutils/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'videoutils/CMakeLists.txt')
-rw-r--r--videoutils/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/videoutils/CMakeLists.txt b/videoutils/CMakeLists.txt
new file mode 100644
index 0000000..c92782c
--- /dev/null
+++ b/videoutils/CMakeLists.txt
@@ -0,0 +1,34 @@
+#
+# Copyright (c) 2018 TOYOTA MOTOR CORPORATION
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+include(FindPkgConfig)
+pkg_check_modules(GLIB2 REQUIRED glib-2.0)
+pkg_check_modules(OPENCV REQUIRED opencv)
+
+set(TARGETS_VIDEO videoutils)
+
+include_directories(${GLIB2_INCLUDE_DIRS} ${OPENCV_INCLUDE_DIRS})
+link_directories(${GLIB2_LIBRARY_DIRS} ${OPENCV_LIBRARY_DIRS})
+link_libraries(${GLIB2_LIBRARIES} ${OPENCV_LIBRARIES})
+
+#add executable file
+add_executable(${TARGETS_VIDEO}
+ videoutils.cpp)
+
+install(TARGETS ${TARGETS_VIDEO}
+ RUNTIME DESTINATION /usr/bin
+)
+