aboutsummaryrefslogtreecommitdiffstats
path: root/Alsa-Plugin/Alsa-Policy-Hook/CMakeLists.txt
diff options
context:
space:
mode:
authorFulup Ar Foll <fulup@iot.bzh>2017-10-24 22:12:48 +0200
committerFulup Ar Foll <fulup@iot.bzh>2017-10-24 22:12:48 +0200
commit6561612a64a52d93260444066a266adb06ac71ad (patch)
tree310cc6cd3fd65e5ed6d02f7743ae2def4ac80644 /Alsa-Plugin/Alsa-Policy-Hook/CMakeLists.txt
parent2fd0fa8c77dbaaf40ba0812e43b6637ff1d1d76e (diff)
Initial working version as independent repo
Diffstat (limited to 'Alsa-Plugin/Alsa-Policy-Hook/CMakeLists.txt')
-rw-r--r--Alsa-Plugin/Alsa-Policy-Hook/CMakeLists.txt37
1 files changed, 0 insertions, 37 deletions
diff --git a/Alsa-Plugin/Alsa-Policy-Hook/CMakeLists.txt b/Alsa-Plugin/Alsa-Policy-Hook/CMakeLists.txt
deleted file mode 100644
index 329b2ef..0000000
--- a/Alsa-Plugin/Alsa-Policy-Hook/CMakeLists.txt
+++ /dev/null
@@ -1,37 +0,0 @@
-###########################################################################
-# Copyright 2015, 2016, 2017 IoT.bzh
-#
-# author: Fulup Ar Foll <fulup@iot.bzh>
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-# Activate ALSA dynamic build build mode get resolve "snd_dlsym_start"
-add_compile_options(-DPIC)
-
-PROJECT_TARGET_ADD(policy_hook_cb)
-
- # Define targets
- ADD_LIBRARY(${TARGET_NAME} MODULE PolicyHookCb.c)
-
- # Alsa Plugin properties
- SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
- PREFIX ""
- OUTPUT_NAME ${TARGET_NAME}
- )
-
- # Library dependencies (include updates automatically)
- TARGET_LINK_LIBRARIES(${TARGET_NAME}
- ${link_libraries}
- )
- install(TARGETS ${TARGET_NAME} LIBRARY DESTINATION lib)