aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorThierry Bultel <thierry.bultel@iot.bzh>2019-01-23 11:27:03 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-02-07 13:01:27 +0000
commit779366b7d9f0e16478a4c15387e26d29b6ba522e (patch)
treed071f7cd8ccf51f1afed3f100e0f25e64df02778 /plugins/lib/CMakeLists.txt
parent48cd4335d91c1341df94e48ca3ea07dbf418bccc (diff)
bluealsa plugin: monitor the state of service via dbus
By monitoring the changes of names on dbus, and by asking dbus for the list of available names at startup, the bluealsa plugin can now be started at whatever time, and is also robust to bluealsa restarts. Moreover, since the bluealsa name has the HCI interface has a suffix (org.bluez-alsa.hci0, for instance), there is not need to hardcode the hci name. Even better, the plugin supports several instances of bluealsa (since the daemon needs one instace per hci device), and will add a watch for added transports for every instance it detects. Complete cleanup of the created streams in softmixer is done when one watched instance disappears. Finnaly, there is a new cmd line '-DWITHOUT_BLUEALSA' option to CMake, for developpers that want to use 4A on host, without the bluealsa library. Default build (SDK, bitbake) consider that the bluealsa shared library is always available. Notice that in the future, the bluealsa library might disappeared, to be replaced by a full dbus interface to bluealsa. BUG-AGL:SPEC-2126 Change-Id: I67fc6edf5147c71dc97f1fc1257d3dadbdde20fc Signed-off-by: Thierry Bultel <thierry.bultel@iot.bzh> (cherry picked from commit fbad8c202c86e4cf6503a99161aabf87ab7a7109)
Diffstat (limited to 'plugins/lib/CMakeLists.txt')
-rw-r--r--plugins/lib/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/plugins/lib/CMakeLists.txt b/plugins/lib/CMakeLists.txt
index 3fd93ec..b41fb3b 100644
--- a/plugins/lib/CMakeLists.txt
+++ b/plugins/lib/CMakeLists.txt
@@ -19,4 +19,6 @@
# Include any directory not starting with _
# -----------------------------------------------------
-PROJECT_SUBDIRS_ADD()
+if (NOT WITHOUT_BLUEALSA)
+PROJECT_SUBDIRS_ADD(bluealsa)
+endif()