aboutsummaryrefslogtreecommitdiffstats
path: root/Ensoniq/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Ensoniq/CMakeLists.txt')
-rw-r--r--Ensoniq/CMakeLists.txt39
1 files changed, 0 insertions, 39 deletions
diff --git a/Ensoniq/CMakeLists.txt b/Ensoniq/CMakeLists.txt
deleted file mode 100644
index cd79e1a..0000000
--- a/Ensoniq/CMakeLists.txt
+++ /dev/null
@@ -1,39 +0,0 @@
-###########################################################################
-# Copyright 2015, 2016, 2017 IoT.bzh
-#
-# author: Fulup Ar Foll <fulup@iot.bzh>
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-###########################################################################
-
-if(HAL_ENSONIQ)
- # Add target to project dependency list
- PROJECT_TARGET_ADD(hal-ensoniq)
-
- # Define project Targets
- ADD_LIBRARY(${TARGET_NAME} MODULE EnsoniqHAL.c)
-
- # Binder exposes a unique public entry point
- SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
- PREFIX "afb-"
- LABELS "BINDING"
- LINK_FLAGS ${BINDINGS_LINK_FLAG}
- OUTPUT_NAME ${TARGET_NAME}
- )
-
- # Library dependencies (include updates automatically)
- TARGET_LINK_LIBRARIES(${TARGET_NAME}
- hal-utilities-4a
- ${link_libraries}
- )
-endif()