summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFulup Ar Foll <fulup@iot.bzh>2017-03-11 00:27:30 +0100
committerFulup Ar Foll <fulup@iot.bzh>2017-03-11 00:27:30 +0100
commit521281617cec5d89725c4844eac68b5a772fab57 (patch)
tree74a5a5154c88cdae485fd2f139d50f3bf003ae9d /CMakeLists.txt
parent5cb52e556fed8eb0cf74d1052fe413fbb7406b0e (diff)
Work in Progress
Static/Dynamic Lib Fixed. Source Tree cleaned up Compile but to be tested Business Logic not done
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 006ff74..0bd639d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -98,18 +98,21 @@ ENDIF(CMAKE_BUILD_TYPE MATCHES Debug)
SET(include_dirs
${INCLUDE_DIRS}
- ${CMAKE_SOURCE_DIR}/AlsaSound/HALayer/include
+ ${CMAKE_CURRENT_SOURCE_DIR}/Common
${json-c_INCLUDE_DIRS}
${afb-daemon_INCLUDE_DIRS}
)
-SET(link_libraries
+# AudioCommon is linked statically with each audiobindings
+SET(link_libraries
+ ${CMAKE_BINARY_DIR}/Common/libaudiocommon.a
${libefence_LIBRARIES}
${json-c_LIBRARIES}
)
# Bindings to compile
# --------------------
+add_subdirectory(Common)
add_subdirectory(AlsaSound)
add_subdirectory(AudioLogic)
add_subdirectory(htdocs)