summaryrefslogtreecommitdiffstats
path: root/HAL-afb/HDA-intel/CMakeLists.txt
diff options
context:
space:
mode:
authorfulup <fulup.arfoll@iot.bzh>2017-04-09 14:35:00 +0200
committerfulup <fulup.arfoll@iot.bzh>2017-04-09 14:35:00 +0200
commit6e70aac6c9f02496978d3d02efb355d66fb36ceb (patch)
treed50df20591076b3da2031b2b9eb249f2a1921f53 /HAL-afb/HDA-intel/CMakeLists.txt
parentc75c329e08f4c189419aa4c5607f38890885b46c (diff)
Clean CMAKE structure and rename files/directories
Diffstat (limited to 'HAL-afb/HDA-intel/CMakeLists.txt')
-rw-r--r--HAL-afb/HDA-intel/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/HAL-afb/HDA-intel/CMakeLists.txt b/HAL-afb/HDA-intel/CMakeLists.txt
new file mode 100644
index 0000000..26be621
--- /dev/null
+++ b/HAL-afb/HDA-intel/CMakeLists.txt
@@ -0,0 +1,41 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Fulup Ar Foll <fulup@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(hal-intel-hda)
+
+ # Define project Targets
+ ADD_LIBRARY(hal-intel-hda MODULE IntelHdaHAL.c)
+
+ # Binder exposes a unique public entry point
+ SET_TARGET_PROPERTIES(hal-intel-hda PROPERTIES
+ PREFIX ""
+ LINK_FLAGS "-Wl,--version-script=${CMAKE_SOURCE_DIR}/export.map"
+ OUTPUT_NAME intel-hda-binding
+ )
+
+ # Library dependencies (include updates automatically)
+ TARGET_LINK_LIBRARIES(hal-intel-hda
+ hal-interface
+ audio-interface
+ )
+
+ # installation directory
+ INSTALL(TARGETS hal-intel-hda
+ LIBRARY DESTINATION ${binding_install_dir})