summaryrefslogtreecommitdiffstats
path: root/clients/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2024-04-18 18:34:47 +0300
committerMarius Vlad <marius.vlad@collabora.com>2024-04-20 17:21:45 +0300
commit6366348eccec778f02061070d1334ea897d4f514 (patch)
tree7a2d7a0bff3c2aaa454a63e021559e012abee468 /clients/meson.build
parentd2510f1e79e501a8e6aecb8058746a7456d1367e (diff)
clients/screenshot: Add support for weston output capture
libweston now provides a protocol which we can use for doing screenshots, not needing to provide one ourselves. This imports a simple client used in Weston but it has some changes to match our current args. Bug-AGL: SPEC-5095 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: I00c9e976975447c74668fbfe1045b9177c623064
Diffstat (limited to 'clients/meson.build')
-rw-r--r--clients/meson.build13
1 files changed, 6 insertions, 7 deletions
diff --git a/clients/meson.build b/clients/meson.build
index 08b2c08..e636894 100644
--- a/clients/meson.build
+++ b/clients/meson.build
@@ -1,20 +1,19 @@
dep_wayland_client = dependency('wayland-client', version: '>= 1.17.0')
+dep_pixman = dependency('pixman-1', version: '>= 0.25.2')
clients = [
{
'basename': 'agl-screenshooter',
'sources': [
- 'screenshooter.c',
+ 'screenshot.c',
'../shared/file-util.c',
'../shared/os-compatibility.c',
'../shared/xalloc.c',
- agl_screenshooter_client_protocol_h,
- agl_screenshooter_protocol_c,
- xdg_output_unstable_v1_client_protocol_h,
- xdg_output_unstable_v1_protocol_c,
+ weston_output_capture_protocol_c,
+ weston_output_capture_client_protocol_h,
],
- 'deps_objs' : [ dep_wayland_client ],
- 'deps': [ 'cairo' ],
+ 'deps_objs' : [ dep_wayland_client, dep_pixman ],
+ 'deps': [ 'cairo', ],
},
]