summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2024-03-26 11:03:03 +0200
committerMarius Vlad <marius.vlad@collabora.com>2024-03-28 15:37:25 +0200
commit612ffac8382b8e51a5b30c09c8cf649dd15877e7 (patch)
treef33b053c99e1f4bfec99d65f1e389e5e49581f2b /meson.build
parent71f98b4252498f48b64f12d069d18f5a490658cf (diff)
compositor/build: Remove HEADLESS backend
Headless backend was introduced to test out the compositor but never materialized. Besides removing headless loading of the backend, also do a bit of clean-up and remove vnc and pipewire strings as we currently have no such backend capability at this moment. Bug-AGL: SPEC-5096, SPEC-5061 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: I87fdc0aa6c41bdcc8b1f53880860df7139ca7ae8
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 7 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index 292308a..3b92cca 100644
--- a/meson.build
+++ b/meson.build
@@ -171,17 +171,17 @@ if libweston_dep.found()
if not meson.is_cross_build()
if not prefix_path.contains('/usr')
dir_path_x11_backend = join_paths(prefix_path, 'include', libweston_version, 'libweston', 'backend-x11.h')
- dir_path_headless_backend = join_paths(prefix_path, 'include', libweston_version, 'libweston', 'backend-headless.h')
+ dir_path_wayland_backend = join_paths(prefix_path, 'include', libweston_version, 'libweston', 'backend-wayland.h')
dir_path_rdp_backend = join_paths(prefix_path, 'include', libweston_version, 'libweston', 'backend-rdp.h')
else
dir_path_x11_backend = join_paths(libweston_version, 'libweston', 'backend-x11.h')
- dir_path_headless_backend = join_paths(libweston_version, 'libweston', 'backend-headless.h')
- dir_path_rdp = join_paths(libweston_version, 'libweston', 'backend-rdp.h')
+ dir_path_wayland_backend = join_paths(libweston_version, 'libweston', 'backend-wayland.h')
+ dir_path_rdp_backend = join_paths(libweston_version, 'libweston', 'backend-rdp.h')
endif
else
message('Building with cross environment')
dir_path_x11_backend = join_paths(libweston_version, 'libweston', 'backend-x11.h')
- dir_path_headless_backend = join_paths(libweston_version, 'libweston', 'backend-headless.h')
+ dir_path_wayland_backend = join_paths(libweston_version, 'libweston', 'backend-wayland.h')
dir_path_rdp_backend = join_paths(libweston_version, 'libweston', 'backend-rdp.h')
endif
@@ -191,9 +191,9 @@ if libweston_dep.found()
message('Building with X11 backend')
endif
- if cc.has_header(dir_path_headless_backend)
- config_h.set('HAVE_BACKEND_HEADLESS', 1)
- message('Building with headless backend')
+ if cc.has_header(dir_path_wayland_backend)
+ config_h.set('HAVE_BACKEND_WAYLAND', 1)
+ message('Building with Wayland backend')
endif
if cc.has_header(dir_path_rdp_backend)