summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2023-09-07 15:29:20 -0400
committerMarius Vlad <marius.vlad@collabora.com>2024-03-11 19:59:16 +0200
commita6ffcf30a926568e269b33b57f3740acfa7bb7f4 (patch)
tree0ee97b87e23c22c74d28412fbd7f662342f0f64d /meson.build
parent7f8195bae3548b25186ca2b7287dd1293fc0d7e5 (diff)
meson.build, src: update for weston 12
Update dependencies for libweston-12 in meson.build, as well as adjust sources due to libweston-desktop/libweston-desktop.h moving to libweston/desktop.h This adds support libweston 12 which includes the following changes: - use MODULEDIR, for both weston and libweston when loading - use backend, renderer when starting up and pass those up Bug-AGL: SPEC-4578 Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: I269e877ee3ae8cf8f1447bda05e11422244a416e
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 55b68cb..99464c3 100644
--- a/meson.build
+++ b/meson.build
@@ -11,7 +11,7 @@ project('agl-compositor',
)
config_h = configuration_data()
-libweston_version = 'libweston-11'
+libweston_version = 'libweston-12'
pkgconfig = import('pkgconfig')
fs = import('fs')
@@ -22,6 +22,7 @@ add_project_arguments(
cc.get_supported_arguments([
'-Wno-unused-parameter',
'-Wno-pedantic',
+ '-Wno-deprecated-declarations'
]),
language: 'c'
)
@@ -123,9 +124,11 @@ deps_libweston = [
dependency('wayland-server'),
dependency('weston'),
libweston_dep,
- dependency('libweston-desktop-11'),
]
+weston_module_dir = libweston_dep.get_pkgconfig_variable('libdir')
+config_h.set_quoted('WESTON_MODULEDIR', join_paths(weston_module_dir, 'weston'))
+config_h.set_quoted('LIBWESTON_MODULEDIR', join_paths(weston_module_dir, libweston_version))
srcs_agl_compositor = [
'src/compositor.c',