aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2016-05-18 18:19:03 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2016-05-18 18:19:03 +0200
commit0ea46ffe93ab87cbd41df1a80d38904d026fcb3b (patch)
tree76720486d33da659acfd52906e7c223a41a88581 /CMakeLists.txt
parent9481b4f2960c560ec8297bdc37d8014230072a5c (diff)
adds a pkgconfig file
Change-Id: Ic0d143f282feef7335c7ea2bf589df90af4eef2f Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 13 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 54cc6407..2e12ec37 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,7 +6,9 @@ SET(CMAKE_POSITION_INDEPENDENT_CODE ON)
SET(PROJECT_NAME "AFB Daemon")
SET(PROJECT_PRETTY_NAME "Application Framework Binder Daemon")
+SET(PROJECT_DESCRIPTION "Secured binder of API for clients of the Application framework")
SET(PROJECT_VERSION "0.4")
+SET(PROJECT_URL "https://github.com/iotbzh/afb-daemon")
INCLUDE(FindPkgConfig)
INCLUDE(CheckIncludeFiles)
@@ -57,7 +59,7 @@ SET(link_libraries
${json-c_LIBRARIES}
)
-SET(plugin_install_dir ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/afb)
+SET(plugin_install_dir ${CMAKE_INSTALL_FULL_LIBDIR}/afb)
ADD_DEFINITIONS(-DPLUGIN_INSTALL_DIR="${plugin_install_dir}")
@@ -65,3 +67,13 @@ ADD_SUBDIRECTORY(src)
ADD_SUBDIRECTORY(include)
ADD_SUBDIRECTORY(plugins)
+############################################################
+# installs the pkgconfig file
+CONFIGURE_FILE(afb-daemon.pc.in afb-daemon.pc @ONLY)
+
+INSTALL(FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/afb-daemon.pc
+ DESTINATION
+ ${CMAKE_INSTALL_FULL_LIBDIR}/pkgconfig
+ )
+