aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2016-05-27 17:15:21 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2016-05-27 17:15:21 +0200
commit13a8c36f354376b622cebb3348f2500d87b980a9 (patch)
treee43c967a07cfc908d8c0e7a4afeb7fb112d31f45 /CMakeLists.txt
parent18439204034fca982b3b65c2d581f80a9ee62f56 (diff)
Adds the library libafbwsc.so
This library is intended to be used by C clients to connect to the binder and access to its fetures through the websocket. An example of integration is given by afb-client-demo.c It is known that it introduces an unwanted dependency to afb-common. This is a temporary issue. Change-Id: Ie0a395f116f6ee05679525a6399ef23ef245c944 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6089f282..c5094bb8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,11 +67,13 @@ ADD_SUBDIRECTORY(include)
ADD_SUBDIRECTORY(plugins)
############################################################
-# installs the pkgconfig file
+# installs the pkgconfig files
CONFIGURE_FILE(afb-daemon.pc.in afb-daemon.pc @ONLY)
+CONFIGURE_FILE(afb-wsc.pc.in afb-wsc.pc @ONLY)
INSTALL(FILES
${CMAKE_CURRENT_BINARY_DIR}/afb-daemon.pc
+ ${CMAKE_CURRENT_BINARY_DIR}/afb-wsc.pc
DESTINATION
${CMAKE_INSTALL_LIBDIR}/pkgconfig
)