aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2016-05-13 16:14:16 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2016-05-13 16:40:41 +0200
commit146f95b776c7a424e672b27386fbb8392bc0ffb7 (patch)
tree890b4ba0c2918609b208b4b8587caa3a1ec179a9 /CMakeLists.txt
parentb5cf93aed93e7f331eb645c8afe5317fb67ee50e (diff)
example of integration with websocket in C
The file src/afb-client-demo.c provides an example of how to make a simple C client that connects to the daemon using the websocket protocol x-afb-json1. Change-Id: I31c926b2c42101a53e1ea36b4f67f095614db4a0 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cee5a07f..12e4be95 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -123,9 +123,3 @@ ADD_DEFINITIONS(-DPLUGIN_INSTALL_DIR="${plugin_install_dir}")
ADD_SUBDIRECTORY(src)
ADD_SUBDIRECTORY(plugins)
-ADD_EXECUTABLE(afb-daemon $<TARGET_OBJECTS:src>)
-INCLUDE_DIRECTORIES(${include_dirs})
-TARGET_LINK_LIBRARIES(afb-daemon ${link_libraries})
-
-INSTALL(TARGETS afb-daemon
- RUNTIME DESTINATION ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_BINDIR})