aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2018-02-26 18:57:24 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2018-02-26 19:04:53 +0100
commit3e3a29fa49ec494800a4aa866d84fba4eaa8261b (patch)
treef580666e31bf07f6598bf6a31e08d91026563e66 /CMakeLists.txt
parentd1e30006b071533ae2d1903251962d2dec452418 (diff)
afs-supervisor: Add systemd service and config
Change-Id: I64bf8de01dbb8cf9581ed0be358d81fa84106520 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1a6d2184..b784621a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,6 +39,11 @@ INCLUDE(CTest)
# possible settings
set(AGL_DEVEL OFF CACHE BOOL "Activates developping features")
set(INCLUDE_MONITORING OFF CACHE BOOL "Activates installation of monitoring")
+set(INCLUDE_SUPERVISOR OFF CACHE BOOL "Activates installation of supervisor")
+set(AFS_SURPERVISION_SOCKET "@urn:AGL:afs:supervision:socket" CACHE STRING "Internal socket for supervision")
+set(AFS_SUPERVISOR_PORT 1619 CACHE STRING "Port of service for the supervisor")
+set(AFS_SUPERVISOR_TOKEN HELLO CACHE STRING "Secret token for the supervisor")
+set(UNITDIR_SYSTEM ${CMAKE_INSTALL_LIBDIR}/systemd/system CACHE STRING "Path to systemd system unit files")
###########################################################################
@@ -80,6 +85,8 @@ PKG_CHECK_MODULES(openssl openssl)
PKG_CHECK_MODULES(uuid uuid)
PKG_CHECK_MODULES(cynara cynara-client)
+ADD_DEFINITIONS("-DAFS_SURPERVISION_SOCKET=\"${AFS_SURPERVISION_SOCKET}\"")
+
IF(AGL_DEVEL)
ADD_DEFINITIONS(-DAGL_DEVEL)
endif()
@@ -176,3 +183,13 @@ ELSE()
)
ENDIF()
+
+IF(INCLUDE_SUPERVISOR)
+ CONFIGURE_FILE(afs-supervisor.service.in afs-supervisor.service @ONLY)
+ INSTALL(FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/afs-supervisor.service
+ DESTINATION
+ ${UNITDIR_SYSTEM}
+ )
+ENDIF()
+