aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2016-05-03 10:03:58 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2016-05-04 11:55:38 +0200
commit5dd6480727cc1ecb12483fc4d971d73176505748 (patch)
tree495925fdba144f609daaad6da07281fd9bd94b69 /CMakeLists.txt
parentf262b0f726ac0577f40525038b779185f144873f (diff)
Switch to libsystemd events
This patch removes part of code that are not specific in favour of a more shared library. Change-Id: I3506e7514181cfbed753559bb65460f95b2141c9 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2ca0e892..4a856289 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -53,6 +53,7 @@ IF(CMAKE_BUILD_TYPE MATCHES Debug)
ENDIF(CMAKE_BUILD_TYPE MATCHES Debug)
INCLUDE(FindPkgConfig)
+PKG_CHECK_MODULES(libsystemd REQUIRED libsystemd)
PKG_CHECK_MODULES(json-c REQUIRED json-c)
PKG_CHECK_MODULES(libmicrohttpd REQUIRED libmicrohttpd>=0.9.48)
PKG_CHECK_MODULES(openssl REQUIRED openssl)
@@ -90,6 +91,7 @@ FIND_PACKAGE(Threads)
SET(include_dirs
${INCLUDE_DIRS}
${CMAKE_SOURCE_DIR}/include
+ ${libsystemd_INCLUDE_DIRS}
${json-c_INCLUDE_DIRS}
${libmicrohttpd_INCLUDE_DIRS}
${uuid_INCLUDE_DIRS}
@@ -102,6 +104,7 @@ SET(include_dirs
)
SET(link_libraries
+ ${libsystemd_LIBRARIES}
${json-c_LIBRARIES}
${libmicrohttpd_LIBRARIES}
${uuid_LIBRARIES}