aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2018-05-03 16:50:55 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2018-05-03 14:59:47 +0000
commit7dd5b65e20137b40df4248d0903e88ce381c3197 (patch)
tree49a03c49c2c618afc0b418aaa18c70b2b3712fd2 /CMakeLists.txt
parent5b26086e8e634d1fcd2e65dc164fd3453f43942b (diff)
CMakeLists: Fix c++ build
On debian, for example, we need to specify C14 compatibility Change-Id: I4fd4d6dbca03d085def61e373617ab5336ebcb0b Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2efee1dd..f60cacee 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -57,6 +57,7 @@ add_compile_options(-Werror=implicit-function-declaration)
add_compile_options(-ffunction-sections -fdata-sections)
add_compile_options(-fPIC)
add_compile_options(-g)
+set (CMAKE_CXX_STANDARD 14)
set(CMAKE_C_FLAGS_PROFILING "-g -O2 -pg -Wp,-U_FORTIFY_SOURCE")
set(CMAKE_C_FLAGS_DEBUG "-g -ggdb -Wp,-U_FORTIFY_SOURCE")