aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2018-09-12 14:35:03 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2018-09-13 14:36:26 +0200
commit80c96d74b4ffe8df5d0567da52776a409b2483bf (patch)
tree3f4df6bb8bc24f8cc0f0114c0da59f31f4f35949 /CMakeLists.txt
parent29f544ba5fa53407575b549c1d3b0a4e2619af8f (diff)
CMakeLists: Use AGLVERSION if set
And default the version to the next version of AGL pre-guppy: 6.90.0 Change-Id: I5955add9307dd2d07a071383950839f1137e7705 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f52f9642..8bee1068 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,7 +23,8 @@ PROJECT(afb-daemon C CXX)
SET(PROJECT_NAME "AFB Daemon")
SET(PROJECT_PRETTY_NAME "Application Framework Binder Daemon")
SET(PROJECT_DESCRIPTION "Secured binder of API for clients of the Application framework")
-SET(PROJECT_VERSION "5.99.FFRC6")
+set(AGLVERSION "6.90.0" CACHE STRING "Version of AGL")
+set(PROJECT_VERSION ${AGLVERSION} CACHE STRING "Version of the project can override AGLVERSION")
set(PROJECT_URL "https://gerrit.automotivelinux.org/gerrit/gitweb?p=src/app-framework-binder.git;a=summary")
SET(LIBAFBWSC_VERSION "1.1")