aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2016-04-19 11:52:18 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2016-04-19 11:52:18 +0200
commit9559bbf8177390eef48117375a4323f8def11907 (patch)
treedb2abfda0494a5dcf3d4f4c874d20aeeb38be5b6 /CMakeLists.txt
parent469e619ac45402471ea7d8c792ffc06e79346ef2 (diff)
temporarily removal of unbuildables
Change-Id: Ic67506010cbce922476552f35411a92940056eb4 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt38
1 files changed, 36 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 03d4aad2..2ca0e892 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -83,8 +83,42 @@ ENDIF(gupnp_FOUND)
INCLUDE(FindThreads)
FIND_PACKAGE(Threads)
-SET(include_dirs ${INCLUDE_DIRS} ${CMAKE_SOURCE_DIR}/include ${json-c_INCLUDE_DIRS} ${libmicrohttpd_INCLUDE_DIRS} ${uuid_INCLUDE_DIRS} ${dbus_INCLUDE_DIRS} ${alsa_INCLUDE_DIRS} ${pulseaudio_INCLUDE_DIRS} ${librtlsdr_INCLUDE_DIRS} ${gupnp_INCLUDE_DIRS} ${openssl_INCLUDE_DIRS})
-SET(link_libraries ${json-c_LIBRARIES} ${libmicrohttpd_LIBRARIES} ${uuid_LIBRARIES} ${dbus_LIBRARIES} ${alsa_LIBRARIES} ${pulseaudio_LIBRARIES} ${librtlsdr_LIBRARIES} ${gupnp_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${libefence_LIBRARIES} ${openssl_LIBRARIES} -lmagic -lm -ldl -lrt)
+#SET(include_dirs ${INCLUDE_DIRS} ${CMAKE_SOURCE_DIR}/include ${json-c_INCLUDE_DIRS} ${libmicrohttpd_INCLUDE_DIRS} ${uuid_INCLUDE_DIRS} ${dbus_INCLUDE_DIRS} ${alsa_INCLUDE_DIRS} ${pulseaudio_INCLUDE_DIRS} ${librtlsdr_INCLUDE_DIRS} ${gupnp_INCLUDE_DIRS} ${openssl_INCLUDE_DIRS})
+#SET(link_libraries ${json-c_LIBRARIES} ${libmicrohttpd_LIBRARIES} ${uuid_LIBRARIES} ${dbus_LIBRARIES} ${alsa_LIBRARIES} ${pulseaudio_LIBRARIES} ${librtlsdr_LIBRARIES} ${gupnp_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT} ${libefence_LIBRARIES} ${openssl_LIBRARIES} -lmagic -lm -ldl -lrt)
+#SET(plugin_install_dir ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/afb)
+
+SET(include_dirs
+ ${INCLUDE_DIRS}
+ ${CMAKE_SOURCE_DIR}/include
+ ${json-c_INCLUDE_DIRS}
+ ${libmicrohttpd_INCLUDE_DIRS}
+ ${uuid_INCLUDE_DIRS}
+ ${dbus_INCLUDE_DIRS}
+# ${alsa_INCLUDE_DIRS}
+# ${pulseaudio_INCLUDE_DIRS}
+# ${librtlsdr_INCLUDE_DIRS}
+# ${gupnp_INCLUDE_DIRS}
+ ${openssl_INCLUDE_DIRS}
+)
+
+SET(link_libraries
+ ${json-c_LIBRARIES}
+ ${libmicrohttpd_LIBRARIES}
+ ${uuid_LIBRARIES}
+ ${dbus_LIBRARIES}
+# ${alsa_LIBRARIES}
+# ${pulseaudio_LIBRARIES}
+# ${librtlsdr_LIBRARIES}
+# ${gupnp_LIBRARIES}
+ ${CMAKE_THREAD_LIBS_INIT}
+# ${libefence_LIBRARIES}
+ ${openssl_LIBRARIES}
+ -lmagic
+ -lm
+ -ldl
+ -lrt
+)
+
SET(plugin_install_dir ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/afb)
ADD_DEFINITIONS(-DPLUGIN_INSTALL_DIR="${plugin_install_dir}")