aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bachmann <manuel.bachmann@iot.bzh>2016-05-11 08:41:50 +0200
committerManuel Bachmann <manuel.bachmann@iot.bzh>2016-05-11 08:41:50 +0200
commita4c89089944e8b101ec39ce19dacf400c16aeabf (patch)
treeeb706da8c51169290042c2503cd517f245dbc5b8 /CMakeLists.txt
parent1e8edd92a04281bddc86fff3db5b407943504aed (diff)
Update Audio plugin, re-enable ALSA/Pulse linking
Audio plugin is now ported to new API and builds again. Signed-off-by: Manuel Bachmann <manuel.bachmann@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1289cece..7c182c25 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,6 +17,7 @@ INCLUDE(GNUInstallDirs)
add_compile_options(-Wall -Wextra -Wconversion)
add_compile_options(-Wno-unused-parameter) # frankly not using a parameter does it care?
+add_compile_options(-Wno-sign-compare -Wno-sign-conversion)
add_compile_options(-Werror=maybe-uninitialized)
add_compile_options(-Werror=implicit-function-declaration)
add_compile_options(-ffunction-sections -fdata-sections)
@@ -96,8 +97,8 @@ SET(include_dirs
${libmicrohttpd_INCLUDE_DIRS}
${uuid_INCLUDE_DIRS}
${dbus_INCLUDE_DIRS}
-# ${alsa_INCLUDE_DIRS}
-# ${pulseaudio_INCLUDE_DIRS}
+ ${alsa_INCLUDE_DIRS}
+ ${pulseaudio_INCLUDE_DIRS}
# ${librtlsdr_INCLUDE_DIRS}
# ${gupnp_INCLUDE_DIRS}
${openssl_INCLUDE_DIRS}
@@ -109,8 +110,8 @@ SET(link_libraries
${libmicrohttpd_LIBRARIES}
${uuid_LIBRARIES}
${dbus_LIBRARIES}
-# ${alsa_LIBRARIES}
-# ${pulseaudio_LIBRARIES}
+ ${alsa_LIBRARIES}
+ ${pulseaudio_LIBRARIES}
# ${librtlsdr_LIBRARIES}
# ${gupnp_LIBRARIES}
${CMAKE_THREAD_LIBS_INIT}