aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-08-27 14:48:05 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2017-08-27 15:00:29 +0200
commitb2a53cb68658ec297d8b66f4c333a287bf70bc37 (patch)
tree89f717a149b3146b41982cfc848e4f63d9294c35 /CMakeLists.txt
parent4c1b833e271c8bf6aa5643deef2d47a1781444ea (diff)
monitoring: Add option --monitoring
Installs basic interface for monitoring and add the option --monitoring / -M to activate the alias /monitoring. This makes the page /monitoring/monitor.html available. Change-Id: Iebe0959f0a5e7c396fe7ce6862d0f9c883733824 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5a8d2d2a..eb2d2d12 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -112,6 +112,20 @@ SET(link_libraries
SET(binding_install_dir ${CMAKE_INSTALL_FULL_LIBDIR}/afb)
+###########################################################################
+# activates the monitoring by default
+set(INCLUDE_MONITORING ON CACHE BOOL "Activates installation of monitoring")
+if(INCLUDE_MONITORING)
+ add_definitions(-DWITH_MONITORING_OTPION)
+ INSTALL(DIRECTORY
+ ${CMAKE_CURRENT_SOURCE_DIR}/test/monitoring
+ DESTINATION
+ ${binding_install_dir}
+ )
+endif()
+
+###########################################################################
+
ADD_SUBDIRECTORY(src)
ADD_SUBDIRECTORY(include)
ADD_SUBDIRECTORY(bindings)