aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-08-29 10:25:50 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2017-08-29 10:25:50 +0200
commitb4d1733a12d6aa1e2f349dbd1dc38943fd571ada (patch)
treeafe4dff4e354e81bd6be38f766b5c4387ac4cef2 /CMakeLists.txt
parente28787235090fdf2be6626e1e0a7e02314013652 (diff)
Rework CMakeList.txt
Explicit options and add a definition for AGL_DEVEL Change-Id: I8419f0b0dfecc1e0171c282573cdf32ae3f09704 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3d7e1d07..1037b43e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,6 +38,11 @@ INCLUDE(GNUInstallDirs)
INCLUDE(CTest)
###########################################################################
+# possible settings
+set(AGL_DEVEL OFF CACHE BOOL "Activates developping features")
+set(INCLUDE_MONITORING OFF CACHE BOOL "Activates installation of monitoring")
+
+###########################################################################
link_libraries(-Wl,--as-needed -Wl,--gc-sections -Wl,--no-undefined)
@@ -82,6 +87,10 @@ PKG_CHECK_MODULES(openssl REQUIRED openssl)
PKG_CHECK_MODULES(uuid REQUIRED uuid)
PKG_CHECK_MODULES(cynara cynara-client)
+IF(AGL_DEVEL)
+ ADD_DEFINITIONS(-DAGL_DEVEL)
+endif()
+
IF(cynara_FOUND)
ADD_DEFINITIONS(-DBACKEND_PERMISSION_IS_CYNARA)
ENDIF(cynara_FOUND)