aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2019-07-09 17:56:55 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2019-07-23 14:24:01 +0200
commitdaecef104cd2a6ac3e4436306e96ed48aea8271d (patch)
tree0115d25bc9476ba044b011802af9c3898e55bde2 /CMakeLists.txt
parent056c53da68eaa007a7bcabf77ef3205b6ff04ca1 (diff)
supervisor: Setup services for local API use
The supervisor only allowed external accesses. This was wrong, it must also allow local access through standard API. This commit fix it. Bug-AGL: SPEC-2660 Signed-off-by: José Bollo <jose.bollo@iot.bzh> Change-Id: Ifa1119a6b2f22c87b1dbe087206d9f51c4005a57
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 54f03b3f..75a50dcf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -198,6 +198,8 @@ ENDIF()
IF(INCLUDE_SUPERVISOR)
CONFIGURE_FILE(afs-supervisor.service.in afs-supervisor.service @ONLY)
INSTALL(FILES
+ ${CMAKE_CURRENT_SOURCE_DIR}/afm-api-supervisor.service
+ ${CMAKE_CURRENT_SOURCE_DIR}/afm-api-supervisor.socket
${CMAKE_CURRENT_BINARY_DIR}/afs-supervisor.service
DESTINATION
${UNITDIR_SYSTEM}