aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-05-29 18:06:55 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2017-05-29 18:06:55 +0200
commite1e9ea2305132b62636b5e6e71a594c86216956a (patch)
tree999404f4b17b7b512951a7b0653a8cbe1855738e /CMakeLists.txt
parent791e07d6476f6758598a68749185a807da253316 (diff)
Add warning on missing undefined symbols
Change-Id: I0ebe3b222cc5f0add9c9d433c0517af4e1910911 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bc201a2a..d06781eb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,7 +39,7 @@ INCLUDE(CTest)
###########################################################################
-link_libraries(-Wl,--as-needed -Wl,--gc-sections)
+link_libraries(-Wl,--as-needed -Wl,--gc-sections -Wl,--no-undefined)
add_compile_options(-Wall -Wextra -Wconversion)
add_compile_options(-Wno-unused-parameter) # frankly not using a parameter does it care?