aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-04-14 19:47:57 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2017-04-14 19:47:57 +0200
commit69d7968b9713dafa23268ee34516e50133ca8b36 (patch)
tree54359bc101c1dc4d7fd6298020dabf1a62674689 /src/CMakeLists.txt
parent9e8b1e1d13cd9c382769014d43d6f2604b396968 (diff)
Create afb-stub-ws by spliting afb-api-ws
The file afb-stub-ws only carries the protocol of the internal remote calling conventions. It as the following benefits: - it easies transition to symetric connection (not planned) - it allows to have server stub on client socket and conversely, client stub on server socket (planned for debugging). Change-Id: I57dc8e78d7bd63427421a180abcb844f8313d37b Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 3b1f1455..fe497fc9 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -77,8 +77,9 @@ ADD_LIBRARY(afb-lib STATIC
afb-msg-json.c
afb-perm.c
afb-session.c
- afb-svc.c
+ afb-stub-ws.c
afb-subcall.c
+ afb-svc.c
afb-websock.c
afb-ws-client.c
afb-ws-json1.c