aboutsummaryrefslogtreecommitdiffstats
path: root/src/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2018-02-07 17:44:20 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2018-02-09 17:26:05 +0100
commitd45426257d5149c735e33e3055220625a919e7bc (patch)
tree50d8a139d507ed7e9f5a632962955acb93889896 /src/tests/CMakeLists.txt
parenteff6f2d1b918186a96d44a225e0bcb4ea2ad7be6 (diff)
afb-session: Refactor and test unit
The session are refactored and now to include a test unit. Change-Id: Ia8c4b707191f3af95c0549b333d14b384a81eaa7 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/tests/CMakeLists.txt')
-rw-r--r--src/tests/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/tests/CMakeLists.txt b/src/tests/CMakeLists.txt
index 774f59ae..7c052f32 100644
--- a/src/tests/CMakeLists.txt
+++ b/src/tests/CMakeLists.txt
@@ -17,3 +17,11 @@
###########################################################################
+PKG_CHECK_MODULES(check check)
+if(check_FOUND)
+ INCLUDE_DIRECTORIES(${INCLUDE_DIRS} ${check_INCLUDE_DIRS})
+ SET(link_libraries ${link_libraries} ${check_LDFLAGS})
+ add_subdirectory(session)
+else(check_FOUND)
+ MESSAGE(WARNING "check not found! no test!")
+endif(check_FOUND)