aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 07fcb8b7..c789fca3 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -26,7 +26,6 @@ ADD_DEFINITIONS(-DINFER_EXTENSION)
ADD_LIBRARY(afb-lib STATIC
afb-api.c
- afb-api-dbus.c
afb-api-dyn.c
afb-api-so.c
afb-api-so-v1.c
@@ -75,6 +74,11 @@ ADD_LIBRARY(afb-lib STATIC
wrap-json.c
)
+IF(INCLUDE_DBUS_TRANSPARENCY)
+ ADD_DEFINITIONS(-DWITH_DBUS_TRANSPARENCY)
+ TARGET_SOURCES(afb-lib PUBLIC afb-api-dbus.c)
+ENDIF()
+
###########################################
# build and install afb-daemon
###########################################