summaryrefslogtreecommitdiffstats
path: root/genskel/CMakeLists.txt
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-11-17 06:07:15 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-11-17 06:16:27 +0100
commit653278b62e5bbea89467787d110d6abb6fccdba2 (patch)
tree18927f3fb39581101e2b6f2da41fd241dcc99807 /genskel/CMakeLists.txt
parent0d53841e3381c60cd6901aaae14bad181ae5fa4d (diff)
Initial upload of genskel as host toolHEADmaster
This change exports the genskel tool from the af-binder repo into its own source tree. The tools is a generator that needs to execute on the compile host. Bug-AGL: SPEC-941 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'genskel/CMakeLists.txt')
-rw-r--r--genskel/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/genskel/CMakeLists.txt b/genskel/CMakeLists.txt
new file mode 100644
index 0000000..6263c85
--- /dev/null
+++ b/genskel/CMakeLists.txt
@@ -0,0 +1,31 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: José Bollo <jose.bollo@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+cmake_minimum_required(VERSION 3.5)
+
+ADD_EXECUTABLE(afb-genskel genskel.c)
+ADD_EXECUTABLE(afb-exprefs exprefs.c)
+ADD_EXECUTABLE(afb-json2c json2c.c)
+
+TARGET_LINK_LIBRARIES(afb-genskel ${link_libraries})
+TARGET_LINK_LIBRARIES(afb-exprefs ${link_libraries})
+TARGET_LINK_LIBRARIES(afb-json2c ${link_libraries})
+
+INSTALL(TARGETS afb-genskel RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+INSTALL(TARGETS afb-exprefs RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+INSTALL(TARGETS afb-json2c RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+