aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2016-10-20 11:12:06 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2016-10-20 12:00:52 +0200
commit18103e986d89b9e329f49d9329d8bc40dffd39eb (patch)
tree2cee41c95354be7f2e3fa7078fd50e2b86770363 /CMakeLists.txt
parent38ba270af828b80e0ffb5eab955aff733de17dba (diff)
build: improve simulation of security
This commits allows to simulates either the security-manager and the smack LSM. These simulations are used for developping purpose. Change-Id: I138d7351511ca2663498bfacca28811fc81b8c55 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e893222..d649186 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,11 +27,13 @@ set(PROJECT_PRETTY_NAME "Application Framework Main")
set(PROJECT_DESCRIPTION "Secured Application framework")
set(PROJECT_VERSION "1.0")
-
set(USE_LIBZIP ON CACHE BOOL "should try to use libzip?")
-set(USE_SIMULATION ON CACHE BOOL "if set simulates security manager")
+set(USE_SIMULATION OFF CACHE BOOL "if set simulates security manager and smack")
set(USE_SDK OFF CACHE BOOL "if set, avoids installating system runtime files")
+set(SIMULATE_SECMGR OFF CACHE BOOL "if set, the security manager is simulated")
+set(SIMULATE_SMACK OFF CACHE BOOL "if set, the smack environment is simulated")
+
set(afm_name "afm" CACHE STRING "Name for application framework user")
set(afm_confdir "${CMAKE_INSTALL_FULL_SYSCONFDIR}/${afm_name}" CACHE STRING "Directory for configuration files")
set(afm_datadir "${CMAKE_INSTALL_FULL_DATADIR}/${afm_name}" CACHE STRING "Root directory for installions")
@@ -42,6 +44,11 @@ set(afm_prefix_binding "${afm_prefix}binding:" CACHE STRING "URN for bindin
set(afm_user_appdir "app-data" CACHE STRING "User subdirectory for applications")
set(wgtpkg_trusted_cert_dir "${afm_confdir}/certs" CACHE STRING "Path to internal certificates")
+if(USE_SIMULATION)
+ set(SIMULATE_SECMGR ON)
+ set(SIMULATE_SMACK ON)
+endif(USE_SIMULATION)
+
add_definitions(
-DFWK_CONFIG_DIR="${afm_confdir}"
-DFWK_PREFIX="${afm_prefix}"