aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJose Bollo <jose.bollo@iot.bzh>2020-01-24 14:49:23 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2020-02-14 09:04:56 +0000
commita855d14583b2ac2629dfac696fea788826bacc4d (patch)
tree5362c1843881e07a317094d132a9de86cc671fd8 /CMakeLists.txt
parent7f53b8188b6b4448dad771eeb8b03160aa314826 (diff)
Remove distinction of widget's version
This removes the distinction between the different versions of a widget. The boolean CMAKE option DISTINCT_VERSIONS allows to switch between the two possibilities: DISTINCT_VERSIONS=OFF (default) Widget installed in {afm_appdir}/{id} Ids of applications have no version part: {id} DISTINCT_VERSIONS=ON (legacy, old default) Widget installed in {afm_appdir}/{id}/{ver} Ids of applications have no version part: {id}@{ver} Bug-AGL: SPEC-2538 Change-Id: I7cb54d4b296b740c553be8a627e66175107e5a4b Signed-off-by: Jose Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 13 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 06086e5..c1d80ce 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -30,15 +30,16 @@ set(AGLVERSION "8.0.0" CACHE STRING "Version of AGL")
set(PROJECT_VERSION ${AGLVERSION} CACHE STRING "Version of the project can override AGLVERSION")
set(PROJECT_URL "https://gerrit.automotivelinux.org/gerrit/gitweb?p=src/app-framework-main.git;a=summary")
-set(USE_LIBZIP ON CACHE BOOL "should try to use libzip?")
-set(USE_SIMULATION OFF CACHE BOOL "if set simulates security manager and smack")
-set(USE_SDK OFF CACHE BOOL "if set, avoids installating system runtime files")
-set(ALLOW_NO_SIGNATURE OFF CACHE BOOL "if set, widgets without signature are accepted")
+option(DISTINCT_VERSIONS "Should the version of application be distinguished" OFF)
+option(USE_LIBZIP "Should try to use libzip?" ON)
+option(USE_SIMULATION "If set simulates security manager and smack" OFF)
+option(USE_SDK "If set, avoids installating system runtime files" OFF)
+option(ALLOW_NO_SIGNATURE "If set, widgets without signature are accepted" OFF)
-set(SIMULATE_SECMGR OFF CACHE BOOL "if set, the security manager is simulated")
-set(SIMULATE_SMACK OFF CACHE BOOL "if set, the smack environment is simulated")
+option(SIMULATE_SECMGR "If set, the security manager is simulated" OFF)
+option(SIMULATE_SMACK "If set, the smack environment is simulated" OFF)
-set(LEGACY_USER_DAEMON OFF CACHE BOOL "compile and install the legacy afm-user-daemon")
+option(LEGACY_USER_DAEMON "compile and install the legacy afm-user-daemon" OFF)
set(afm_name "afm" CACHE STRING "Name for application framework user")
set(afm_confdir "${CMAKE_INSTALL_FULL_SYSCONFDIR}/${afm_name}" CACHE STRING "Directory for configuration files")
@@ -78,7 +79,11 @@ if(ALLOW_NO_SIGNATURE)
else(ALLOW_NO_SIGNATURE)
add_definitions(-DDEFAULT_ALLOW_NO_SIGNATURE=0)
endif(ALLOW_NO_SIGNATURE)
-
+if(DISTINCT_VERSIONS)
+ add_definitions(-DDISTINCT_VERSIONS=1)
+else(DISTINCT_VERSIONS)
+ add_definitions(-DDISTINCT_VERSIONS=0)
+endif(DISTINCT_VERSIONS)
add_subdirectory(src)
add_subdirectory(conf)