aboutsummaryrefslogtreecommitdiffstats
path: root/conf/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastien Douheret <sebastien.douheret@iot.bzh>2017-07-13 22:02:20 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2017-07-24 09:34:03 +0200
commitd06b3d9f5bae5424bcada675eaece47b56eb9e3d (patch)
tree93247930e8516d0e1f8cdec3d0c3ea6bd4d84ea2 /conf/CMakeLists.txt
parent5ac881fc974222d7416507ad36e13e1a811fe22e (diff)
Add service debugging support (afm-debug).dab_4.0.0dab/4.0.04.0.0
Add necessary tools/scripts, such as afm-debug, to allow service binding. These tools are only available in develvopment (AGL_DEVEL is set). Change-Id: I4e946146af985c74c8bd97d8c118b932394bbc5e Signed-off-by: Sebastien Douheret <sebastien.douheret@iot.bzh> Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'conf/CMakeLists.txt')
-rw-r--r--conf/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/conf/CMakeLists.txt b/conf/CMakeLists.txt
index cf3d3ec..5f15dd6 100644
--- a/conf/CMakeLists.txt
+++ b/conf/CMakeLists.txt
@@ -20,6 +20,7 @@ cmake_minimum_required(VERSION 2.8)
configure_file(afm-launch.conf.in afm-launch.conf)
configure_file(afm-unit.conf.in afm-unit.conf)
+configure_file(afm-unit-debug.conf.in afm-unit-debug.conf)
configure_file(afm-system-daemon.service.in afm-system-daemon.service)
configure_file(afm-user-daemon.service.in afm-user-daemon.service)
@@ -34,7 +35,12 @@ if(NOT USE_SDK)
install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/afm-user-daemon.conf DESTINATION ${SYSCONFDIR_DBUS_USER})
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/afm-user-daemon.service DESTINATION ${UNITDIR_USER})
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/afm-launch.conf DESTINATION ${afm_confdir})
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/afm-unit.conf DESTINATION ${afm_confdir})
install(DIRECTORY DESTINATION ${afm_confdir}/unit.env.d)
+
+ if(AGL_DEVEL)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/afm-unit-debug.conf DESTINATION ${afm_confdir} RENAME afm-unit.conf)
+ else()
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/afm-unit.conf DESTINATION ${afm_confdir})
+ endif()
endif()