aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2018-02-27 15:07:54 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2018-02-28 09:15:17 +0100
commit3d50d615fbd4322315dd66859d886576e208b36d (patch)
treecb94b3865a65f5210d253eb52763ea68bfad68ba /scripts/CMakeLists.txt
parente6fc32e9185b5d6c1ea97714a37f1112b54f64fb (diff)
Add configuration variables for runtime socket dirs
2 new configuration variables: - afm_platform_rundir (default /run/platform) Path to location of platform runtime sockets - afm_users_rundir (default /run/user) Path to location of users runtime sockets Change-Id: I65007fee1ca2ce6f1247a67ba0b121f97c08f209 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'scripts/CMakeLists.txt')
-rw-r--r--scripts/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
index e0f80ac..b1ba1d7 100644
--- a/scripts/CMakeLists.txt
+++ b/scripts/CMakeLists.txt
@@ -19,10 +19,12 @@
cmake_minimum_required(VERSION 2.8)
if(NOT USE_SDK)
- install(PROGRAMS afm-util DESTINATION ${CMAKE_INSTALL_BINDIR})
+ configure_file(afm-util.in afm-util)
+ install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/afm-util DESTINATION ${CMAKE_INSTALL_BINDIR})
install(PROGRAMS afm-install DESTINATION ${CMAKE_INSTALL_BINDIR})
if(AGL_DEVEL)
- install(PROGRAMS afm-debug DESTINATION ${CMAKE_INSTALL_BINDIR})
+ configure_file(afm-debug.in afm-debug)
+ install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/afm-debug DESTINATION ${CMAKE_INSTALL_BINDIR})
endif()
endif()