aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2019-09-13 16:46:39 +0200
committerJosé Bollo <jose.bollo@iot.bzh>2020-02-28 12:19:23 +0100
commit0083ad3751cd2b088b5c5d0dea727671ea2a3cca (patch)
tree8163694e0c2523b861f84e45ec14cc6d1a760f41 /src/CMakeLists.txt
parent4f888279f132faf35caf92d4828f134f6daeb9a1 (diff)
Rename source files and improve readability
Also rename wgtpkg-installer tools as wgtpkg-install. Shorter and obvious. Bug-AGL: SPEC-2840 Change-Id: Ifed072bfef488700807613dd61875a30a4041d7a Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 0fde569..3a94d0d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -148,19 +148,19 @@ add_library(afm STATIC
MESSAGE(STATUS "Creating packaging tools")
-add_executable(wgtpkg-sign wgtpkg-sign.c)
+add_executable(wgtpkg-sign main-wgtpkg-sign.c)
target_link_libraries(wgtpkg-sign wgtpkg utils)
-add_executable(wgtpkg-pack wgtpkg-pack.c)
+add_executable(wgtpkg-pack main-wgtpkg-pack.c)
target_link_libraries(wgtpkg-pack wgtpkg utils)
-add_executable(wgtpkg-info wgtpkg-info.c)
+add_executable(wgtpkg-info main-wgtpkg-info.c)
target_link_libraries(wgtpkg-info wgtpkg wgt utils)
-add_executable(wgtpkg-installer wgtpkg-installer.c)
-target_link_libraries(wgtpkg-installer wgtpkg wgt secwrp utils)
+add_executable(wgtpkg-install main-wgtpkg-install.c)
+target_link_libraries(wgtpkg-install wgtpkg wgt secwrp utils)
-install(TARGETS wgtpkg-sign wgtpkg-pack wgtpkg-info wgtpkg-installer DESTINATION ${CMAKE_INSTALL_BINDIR})
+install(TARGETS wgtpkg-sign wgtpkg-pack wgtpkg-info wgtpkg-install DESTINATION ${CMAKE_INSTALL_BINDIR})
###########################################################################
# dynamic tool daemons