aboutsummaryrefslogtreecommitdiffstats
path: root/conf/dbus/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'conf/dbus/CMakeLists.txt')
-rw-r--r--conf/dbus/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/conf/dbus/CMakeLists.txt b/conf/dbus/CMakeLists.txt
new file mode 100644
index 0000000..9946595
--- /dev/null
+++ b/conf/dbus/CMakeLists.txt
@@ -0,0 +1,28 @@
+###########################################################################
+# Copyright (C) 2015-2019 IoT.bzh
+#
+# author: José Bollo <jose.bollo@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+cmake_minimum_required(VERSION 2.8)
+
+if(NOT USE_SDK)
+ set(SYSCONFDIR_DBUS_SYSTEM ${CMAKE_INSTALL_SYSCONFDIR}/dbus-1/system.d CACHE STRING "Path to dbus system configuration files")
+ set(SYSCONFDIR_DBUS_SESSION ${CMAKE_INSTALL_SYSCONFDIR}/dbus-1/session.d CACHE STRING "Path to dbus system configuration files")
+
+ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/afm-permissions-system.conf DESTINATION ${SYSCONFDIR_DBUS_SYSTEM})
+ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/afm-permissions-session.conf DESTINATION ${SYSCONFDIR_DBUS_SESSION})
+endif()
+