summaryrefslogtreecommitdiffstats
path: root/examples/hybrid-html5/app/CMakeLists.txt
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2017-05-04 11:57:27 +0200
committerRomain Forlot <romain.forlot@iot.bzh>2018-10-15 18:21:42 +0200
commit02075924e861edb74935266cc722d362af87a9f0 (patch)
tree2502dc6908dbc49ffac4095be0615afd71611b92 /examples/hybrid-html5/app/CMakeLists.txt
parent917a08ff30f6f1f8bf89b3dea951d02b265eacf2 (diff)
Continue separation of sources and put also html5 into separated dir
Change-Id: I36bc61f69f0e2d197f1891f3ea7cfa30e9a29e3b Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'examples/hybrid-html5/app/CMakeLists.txt')
-rw-r--r--examples/hybrid-html5/app/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/examples/hybrid-html5/app/CMakeLists.txt b/examples/hybrid-html5/app/CMakeLists.txt
new file mode 100644
index 0000000..a862b3c
--- /dev/null
+++ b/examples/hybrid-html5/app/CMakeLists.txt
@@ -0,0 +1,38 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Romain Forlot <romain.forlot@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(hybrid-html5-example)
+
+ # Define project Targets
+ add_custom_command(OUTPUT dist.prod
+ DEPENDS ${TARGET_NAME}
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+ COMMAND npm install
+ COMMAND gulp widget-config-prod
+ COMMAND cp -r dist.prod ${CMAKE_CURRENT_BINARY_DIR})
+
+ add_custom_target(${TARGET_NAME} ALL DEPENDS dist.prod)
+
+ # Binder exposes a unique public entry point
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ PREFIX ""
+ LABELS "HTDOCS"
+ OUTPUT_NAME dist.prod)
+
+populate_widget()