summaryrefslogtreecommitdiffstats
path: root/examples/qml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/qml/CMakeLists.txt')
-rw-r--r--examples/qml/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/examples/qml/CMakeLists.txt b/examples/qml/CMakeLists.txt
new file mode 100644
index 0000000..c8d1bbb
--- /dev/null
+++ b/examples/qml/CMakeLists.txt
@@ -0,0 +1,44 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# author: Romain Forlot <romain.forlot@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+CMAKE_MINIMUM_REQUIRED(VERSION 3.3)
+
+include(${CMAKE_CURRENT_SOURCE_DIR}/etc/config.cmake)
+include(${CMAKE_CURRENT_SOURCE_DIR}/etc/macros.cmake)
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(qml-example)
+
+ add_custom_command(OUTPUT xxxxxx-qml-app.qml
+ COMMAND cp ${CMAKE_CURRENT_SOURCE_DIR}/xxxxxx-qml-app.qml ${CMAKE_CURRENT_BINARY_DIR}
+ )
+
+ # Define project Targets
+ add_custom_target(${TARGET_NAME} ALL
+ DEPENDS xxxxxx-qml-app.qml
+ )
+
+ # Binder exposes a unique public entry point
+ SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+ PREFIX ""
+ LABELS "EXECUTABLE"
+ OUTPUT_NAME xxxxxx-qml-app.qml)
+
+populate_widget()
+
+build_widget()