aboutsummaryrefslogtreecommitdiffstats
path: root/systemd/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2019-12-12 18:10:48 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2019-12-13 16:00:27 +0100
commitc29761cd1628960ee2b11a469763479ac5ef1dfa (patch)
tree5bca3e838d04fc87814dcf9ce476679d15ab4f86 /systemd/CMakeLists.txt
parent23bc1035a51fe54600db691981f8ed1537cbe125 (diff)
Improve integration of cynagoraicefish_8.99.4icefish/8.99.48.99.4
Allow to be more flexible when starting with or without systemd. At end this change will allows to start within systemd with socket activation or not and by sending notification without need of option. Make setting of the sockets more accurate. The admin and agent socket are now accessible only to clients of the expected group, cynagora by default. Bug-AGL: SPEC-3230 Bug-AGL: SPEC-2968 Change-Id: I3e5c7c00dfa0494628c18ffc016cfc8599a5bf9b Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'systemd/CMakeLists.txt')
-rw-r--r--systemd/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/systemd/CMakeLists.txt b/systemd/CMakeLists.txt
index c68f7f5..bb9d059 100644
--- a/systemd/CMakeLists.txt
+++ b/systemd/CMakeLists.txt
@@ -19,12 +19,13 @@
set(SYSTEMD_UNIT_DIR "${CMAKE_INSTALL_FULL_LIBDIR}/systemd/system"
CACHE PATH "Path to systemd system unit files")
+CONFIGURE_FILE(cynagora.service.in cynagora.service @ONLY)
CONFIGURE_FILE(cynagora-admin.socket.in cynagora-admin.socket @ONLY)
CONFIGURE_FILE(cynagora-check.socket.in cynagora-check.socket @ONLY)
CONFIGURE_FILE(cynagora-agent.socket.in cynagora-agent.socket @ONLY)
INSTALL(FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/cynagora.service
+ ${CMAKE_CURRENT_BINARY_DIR}/cynagora.service
${CMAKE_CURRENT_SOURCE_DIR}/cynagora.target
${CMAKE_CURRENT_BINARY_DIR}/cynagora-admin.socket
${CMAKE_CURRENT_BINARY_DIR}/cynagora-check.socket