aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt29
1 files changed, 15 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c96027b..5879513 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,24 +16,25 @@
# limitations under the License.
###########################################################################
-CMAKE_MINIMUM_REQUIRED(VERSION 3.0)
+cmake_minimum_required(VERSION 3.0)
-PROJECT(cynara C)
+project(cynara C)
-SET(PROJECT_NAME "Cynara")
-SET(PROJECT_PRETTY_NAME "Permission database")
-SET(PROJECT_DESCRIPTION "Secured permission database for applications")
-SET(PROJECT_VERSION "1.99.99")
+set(PROJECT_NAME "Cynara")
+set(PROJECT_PRETTY_NAME "Permission database")
+set(PROJECT_DESCRIPTION "Secured permission database for applications")
+set(PROJECT_VERSION "1.99.99")
set(PROJECT_URL "https://gerrit.automotivelinux.org/gerrit/gitweb?p=src/cynara.git;a=summary")
-INCLUDE(FindPkgConfig)
-INCLUDE(CheckIncludeFiles)
-INCLUDE(CheckLibraryExists)
-INCLUDE(GNUInstallDirs)
+include(FindPkgConfig)
+include(CheckIncludeFiles)
+include(CheckLibraryExists)
+include(GNUInstallDirs)
+include(CTest)
+
if(NOT CMAKE_INSTALL_FULL_RUNSTATEDIR)
- set(CMAKE_INSTALL_FULL_RUNSTATEDIR "${CMAKE_INSTALL_FULL_LOCALSTATEDIR}/run")
+ set(CMAKE_INSTALL_FULL_RUNSTATEDIR "${CMAKE_INSTALL_FULL_LOCALSTATEDIR}/run")
endif()
-INCLUDE(CTest)
###########################################################################
# possible settings
@@ -76,8 +77,8 @@ set(CMAKE_C_FLAGS_CCOV "-g -O2 --coverage")
###########################################################################
if(SYSTEMD)
- PKG_CHECK_MODULES(libsystemd REQUIRED libsystemd>=222)
- add_subdirectory(systemd)
+ PKG_CHECK_MODULES(libsystemd REQUIRED libsystemd>=222)
+ add_subdirectory(systemd)
endif()
add_subdirectory(include)