aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYury Asheshov <yury.asheshov@k2l.de>2015-12-15 17:18:35 +0000
committerManuel Bachmann <mbc@iot.bzh>2015-12-15 17:18:35 +0000
commit253e3d98505108f652ba875544fde4f58d4714c8 (patch)
treec3cec0ec4959fc54a437ee78dd791be83bb2e213 /CMakeLists.txt
Initial commit
Signed-off-by: Manuel Bachmann <mbc@iot.bzh> Author: Yury Asheshov <yury.asheshov@k2l.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..f8d0e5b
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,22 @@
+PROJECT(hvacplugin CXX)
+SET(CMAKE_CXX_FLAGS "-std=c++11 ${CMAKE_CXX_FLAGS}")
+
+include(FindPkgConfig)
+pkg_check_modules(gio gio-2.0)
+pkg_check_modules(gio-unix gio-unix-2.0)
+pkg_check_modules(json-c json-c)
+pkg_check_modules(amb automotive-message-broker)
+set(Boost_INCLUDE_DIRS /usr/include/boost)
+
+include_directories(${CMAKE_SOURCE_DIR}/lib ${include_dirs} ${gio_INCLUDE_DIRS} ${gio-unix_INCLUDE_DIRS} ${CMAKE_SOURCE_DIR}/plugins/common ${Boost_INCLUDE_DIRS} ${json-c_INCLUDE_DIRS} ${amb_INCLUDE_DIRS})
+
+set(hvacplugin_headers hvacplugin.h)
+set(hvacplugin_sources hvacplugin.cpp)
+
+add_library(hvacplugin MODULE ${hvacplugin_sources} ${hvacplugin_headers})
+set_target_properties(hvacplugin PROPERTIES PREFIX "")
+target_link_libraries(hvacplugin amb amb-plugins-common -L${CMAKE_CURRENT_BINARY_DIR}/plugins/common ${link_libraries} -lrt ${json-c_LIBRARIES})
+
+install(TARGETS hvacplugin LIBRARY DESTINATION ${PLUGIN_INSTALL_PATH})
+
+