aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2021-04-15 11:17:32 +0000
committerNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2021-04-15 11:17:32 +0000
commit738c1d56adb80ac3623251a47a7c5f2d4db57193 (patch)
treeeba82b97376f605ba4ed92464fceeea71f4045cc /CMakeLists.txt
Initial commit for AGL cluster ipc library
This source code is AGL instrument cluster common ipc library. Currently, this source code is missing author information, license and other. Will be add by author. Author: Nozomu Abe (nozo_abe@nippon-seiki.co.jp) Committed by Naoto Yamaguchi. Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..501bf48
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,32 @@
+project(ipc C)
+
+cmake_minimum_required(VERSION 2.8)
+
+# set gcc flags
+set(CMAKE_C_FLAGS "-Wall -O2")
+
+# Build option for DEBUG
+option(DEBUG_BUILD "This is debug build." OFF)
+if(DEBUG_BUILD)
+ add_definitions(-DDEBUG)
+ set(CMAKE_INSTALL_PREFIX ${CMAKE_CURRENT_BINARY_DIR}/installdir/usr CACHE PATH "..." FORCE)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -g")
+endif()
+
+include(GNUInstallDirs)
+set(IPC_LIBRARY_VERSION "1.0.0")
+
+# Name of library API
+set(TARGET_NAME ipc)
+
+# Name of IC-service server API
+#set(SERVER_API_NAME cluster_server_api)
+
+# Subdirectories
+add_subdirectory(src)
+add_subdirectory(ipc_unit_test)
+
+configure_file(ipc.pc.in ipc.pc @ONLY)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/ipc.pc
+ DESTINATION
+ ${CMAKE_INSTALL_LIBDIR}/pkgconfig)