summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRaquel Medina <raquel.medina@konsulko.com>2020-05-04 10:57:37 +0200
committerRaquel Medina <raquel.medina@konsulko.com>2020-05-04 11:08:06 +0200
commitbe7f78b632635c51089dc60f5bf178cc5db60350 (patch)
tree37b4d81ad2be449a813491d73c442284a1ac220f /CMakeLists.txt
parentc34c355242319fcb5fb2385040a4d7f819f0afc6 (diff)
share MessageEngine instance
Share MessageEngine instance among clients in the same process using a common socket (same url). - add MessageEngineFactory class; - extend std::unordered_map<> to use QString as key; - use std::shared_ptr<MessageEngine> to share ownership among MessageEngineFactory and the engine clients; - force MessagEngine parent object null to avoid life cycle dependency on a parent; - protect insertions & deletions in m_calls map; Also, not directly related but as part of testing these changes: cleanup on voice to remove superflous model sorting (there's just one voice model for alexa voice agent). Bug-AGL: SPEC-3112 Signed-off-by: Raquel Medina <raquel.medina@konsulko.com> Change-Id: Ie2304453dc37723dac13d256286eeb85f84ca2ab
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b2f826f..696b8bd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -61,8 +61,8 @@ set (SUBDIRS
voice-capabilities
weather)
-add_headers(message.h messagefactory.h messageengine.h responsemessage.h callmessage.h eventmessage.h)
-add_sources(message.cpp messagefactory.cpp messageengine.cpp responsemessage.cpp callmessage.cpp eventmessage.cpp)
+add_headers(message.h messagefactory.h messageengine.h messageenginefactory.h responsemessage.h callmessage.h eventmessage.h utils.h)
+add_sources(message.cpp messagefactory.cpp messageengine.cpp messageenginefactory.cpp responsemessage.cpp callmessage.cpp eventmessage.cpp)
foreach(subdir ${SUBDIRS})
add_subdirectory(${subdir})