summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-12-16 15:07:44 -0500
committerScott Murray <scott.murray@konsulko.com>2021-12-16 16:03:51 -0500
commitfad93b42c285ffb463e9494070f40d3b339d732f (patch)
tree6ae60914c578bd34b8ebbde9b271859e8b87ab65 /CMakeLists.txt
parentfe20f1b029f67dee1f790ade7a9114086f2abd38 (diff)
Initial rework to replace app framework usage
Changes: - Remove "core" code related to WebSocket messaging for the app framework. - Stub out hvac, navigation, network, and weather interfaces. This allows building several of the demo applications without modification for now. The network interface will definitely be reused to plumb in a new connman-glib library derived from the previous network binding. The others may potentially be reused to plumb in other new backend implementations. - Update the Network interface object constructor arguments to add a agent registration flag. This prepares for the connman-glib switch and means users will not need to be updated twice. - Update the Bluetooth interface to use a new bluez-glib library that is derived from the previous Bluetooth binding. This has been successfully tested with a the Settings application. - Remove signal-composer and voice API interface code as there are no direct replacements planned. The signal-composer interface was effectively exposing the binding events, so has little reuse potential with a new backend. For the voice interface, if some form of Alexa support becomes desirable, it can potentially be brought back for adaptation if required. - Disable compilation of the remaining interfaces for now. Some like map, pbap, and mediaplayer are very likely to be used as the basis for updating their associated applications, so keeping the code for the planned iterative development seems easier. - Updated copyright lines in all touched files. Bug-AGL: SPEC-4182 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ib717ac8ac68ec457eaee74755dcf9d4f36b79d12
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt27
1 files changed, 6 insertions, 21 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 28b724c..f69e364 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,42 +7,27 @@ set(CMAKE_AUTOMOC ON)
set(OE_QMAKE_PATH_EXTERNAL_HOST_BINS $ENV{OE_QMAKE_PATH_HOST_BINS})
find_package(Qt5Qml REQUIRED)
-find_package(Qt5WebSockets REQUIRED)
+
+find_package(PkgConfig REQUIRED)
+pkg_check_modules(glib REQUIRED IMPORTED_TARGET glib-2.0)
+pkg_check_modules(bluez_glib REQUIRED IMPORTED_TARGET bluez-glib)
+pkg_check_modules(connman_glib REQUIRED IMPORTED_TARGET connman-glib)
include(GNUInstallDirs)
set(DEST_DIR "${CMAKE_INSTALL_PREFIX}")
-set(PRIVATE_LIBS "${PRIVATE_LIBS} -lqtappfw-core
- -lqtappfw-bt
+set(PRIVATE_LIBS "${PRIVATE_LIBS} -lqtappfw-bt
-lqtappfw-hvac
- -lqtappfw-bt-map
- -lqtappfw-mediaplayer
-lqtappfw-navigation
-lqtappfw-network
- -lqtappfw-bt-pbap
- -lqtappfw-radio
- -lqtappfw-signal-composer
- -lqtappfw-phone
- -lqtappfw-voice
- -lqtappfw-voice-metadata
-lqtappfw-weather")
-
set (SUBDIRS
- core
docs
bluetooth
hvac
- map
- mediaplayer
navigation
network
- pbap
- radio
- signal-composer
- telephony
- voice
- voice-capabilities
weather)
foreach(subdir ${SUBDIRS})