summaryrefslogtreecommitdiffstats
path: root/hvac/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-09-10 12:31:13 -0400
committerScott Murray <scott.murray@konsulko.com>2022-09-21 14:34:40 +0000
commit7573b0647a78baa3346b6a1a964ece01ed49a86c (patch)
tree1f5c6469b67dafed5b6494ea37ee2dc706786738 /hvac/CMakeLists.txt
parent6420728323808d6eea8f83688631f149af186e5d (diff)
Add applaunchd gRPC API wrapper
Changes: - Add applaunchd gRPC API wrapper in applauncher directory, clients can include AppLauncherClient.h to use it. - To facilitate generating protobuf and gRPC code with protoc, switch from CMake to meson for building. While the code generation can be done in CMake, it is a lot more straightforward with meson, and if use of this library continues meson will be easier to maintain. Known issues: - The behavior of the client implementation here with respect to the server side (i.e. applaunchd) going away is currently robust, but could stand improvement with some further investigation. As the code stands, starting applications works when applaunchd becomes available again, but the streaming status RPC that is tied to window activation in the homescreen does not reconnect, and there seem to be some things that need to be resolved with respect to Qt object connection expiry to do so. If the Qt demos continue to be used in a significant fashion, this may be worth picking up. Bug-AGL: SPEC-4559 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I5cb480d4ce4d1cb944ebfd4114fb305f09f28ea3 (cherry picked from commit 560d902f4d2bf4ba3bb2edba6436080ee7d5a5ac)
Diffstat (limited to 'hvac/CMakeLists.txt')
-rw-r--r--hvac/CMakeLists.txt19
1 files changed, 0 insertions, 19 deletions
diff --git a/hvac/CMakeLists.txt b/hvac/CMakeLists.txt
deleted file mode 100644
index ba62be7..0000000
--- a/hvac/CMakeLists.txt
+++ /dev/null
@@ -1,19 +0,0 @@
-
-CONFIGURE_FILE("qtappfw-hvac.pc.in" "qtappfw-hvac.pc" @ONLY)
-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/qtappfw-hvac.pc
- DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
-
-add_library(qtappfw-hvac SHARED hvac.cpp)
-
-target_include_directories(qtappfw-hvac PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}")
-target_include_directories(qtappfw-hvac PUBLIC "${CMAKE_INSTALL_INCLUDEDIR}")
-
-target_link_libraries(qtappfw-hvac Qt5::Core qtappfw-vehicle-signals)
-set_target_properties(qtappfw-hvac PROPERTIES
- VERSION ${PROJECT_VERSION}
- SOVERSION 1
- PUBLIC_HEADER hvac.h)
-
-install(TARGETS qtappfw-hvac
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
- PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/qtappfw-hvac)