summaryrefslogtreecommitdiffstats
path: root/hvac/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-06-16 00:43:21 -0400
committerScott Murray <scott.murray@konsulko.com>2022-07-04 21:23:25 +0000
commitb2cb90d9f5e3e87e963e42f4320edcfad8391f50 (patch)
tree1b34e6c1cfbaac24e22a56f06daac59ee8327ca6 /hvac/CMakeLists.txt
parent607f2b680891c25b51917d5b7f20bc3a3ffc6a65 (diff)
Reimplement HVAC API with VIS signals
Reimplement the HVAC interface with use of VIS signals. There is some impedance mismatching done between VIS signal notifications and the API Qt signals to avoid changing the clients signficantly for now. If the Qt demo lifetime is extended, this may be revisited to either switch to directly using the VehicleSignals interface or doing a more granular mapping that works better with the VSS schema and VIS. Bug-AGL: SPEC-4409 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I6f1763836945600d84d6f70faea40eaa7d45ce27 (cherry picked from commit 01a723bf51a286b4a6b984a6115c2835d9e99b73)
Diffstat (limited to 'hvac/CMakeLists.txt')
-rw-r--r--hvac/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/hvac/CMakeLists.txt b/hvac/CMakeLists.txt
index dd0ceea..ba62be7 100644
--- a/hvac/CMakeLists.txt
+++ b/hvac/CMakeLists.txt
@@ -8,7 +8,7 @@ add_library(qtappfw-hvac SHARED hvac.cpp)
target_include_directories(qtappfw-hvac PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}")
target_include_directories(qtappfw-hvac PUBLIC "${CMAKE_INSTALL_INCLUDEDIR}")
-target_link_libraries(qtappfw-hvac Qt5::Core)
+target_link_libraries(qtappfw-hvac Qt5::Core qtappfw-vehicle-signals)
set_target_properties(qtappfw-hvac PROPERTIES
VERSION ${PROJECT_VERSION}
SOVERSION 1