summaryrefslogtreecommitdiffstats
path: root/telephony/meson.build
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-11-19 13:19:46 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-11-19 13:19:56 +0100
commit4f75c049e8ba1e7fd4f1094f9ed8b681318f021d (patch)
treeaa98230ff962aeba9775c459515b229c8eac47a0 /telephony/meson.build
parent1d78b4a6f9ba4807901c6fc30ece2b84754908e8 (diff)
Import Qt6 conversion patchHEADmaster
Import the patches for the demo applications into the app repos. Bug-AGL: SPEC-5294 Change-Id: I516a951cdd49dbfb1729bf4e49360333b951bad3 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'telephony/meson.build')
-rw-r--r--telephony/meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/telephony/meson.build b/telephony/meson.build
index 934d70c..f32777f 100644
--- a/telephony/meson.build
+++ b/telephony/meson.build
@@ -1,14 +1,14 @@
-qt5_dep = dependency('qt5', modules: ['Qml'])
+qt_dep = dependency('qt6', modules: ['Qml'])
-moc_files = qt5.compile_moc(headers: 'telephony.h',
- dependencies: qt5_dep)
+moc_files = qt.compile_moc(headers: 'telephony.h',
+ dependencies: qt_dep)
src = ['telephony.cpp', moc_files]
lib = shared_library('qtappfw-phone',
sources: src,
version: '1.0.0',
soversion: '0',
- dependencies: qt5_dep,
+ dependencies: qt_dep,
install: true)
install_headers('telephony.h')
@@ -18,5 +18,5 @@ pkg_mod.generate(libraries : lib,
version : '1.0',
name : 'libqtappfw-phone',
filebase : 'qtappfw-phone',
- requires: 'Qt5Qml',
+ requires: 'Qt6Qml',
description : 'Library wrapping AGL telephony API in Qt objects')