summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorArthur Guyader <arthur.guyader@iot.bzh>2019-08-29 15:10:39 +0200
committerArthur Guyader <arthur.guyader@iot.bzh>2019-08-29 18:10:56 +0200
commitd9c40fd96e31ce41166e2b846301335ed6fe5d37 (patch)
treed97480eb71cf39a13d7c89a297ff5a3b9aaa5bfb /src/CMakeLists.txt
parent7869e2e2ca1feb6a85919eab7c1da9c698d6d680 (diff)
This commit allows to generate a file according to the version. And adds the wrapper function for new decoder between v1 and v2. Bug-AGL : SPEC-2780 Change-Id: I169d5a8213d6a14e5d77b600e14b36f0878b3efe Signed-off-by: Arthur Guyader <arthur.guyader@iot.bzh>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 2824b71..5da7e6e 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -28,7 +28,9 @@ add_executable(${TARGET_NAME}
openxc/command.cpp
openxc/diagnostic_message.cpp
openxc/mapping.cpp
- openxc/signal.cpp)
+ openxc/signal.cpp
+ openxc/decoder.cpp
+ )
TARGET_INCLUDE_DIRECTORIES(${TARGET_NAME}
PUBLIC ${CMAKE_CURRENT_SOURCE_DIR}/../3rdparty/json