aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-08-28 17:37:48 -0400
committerScott Murray <scott.murray@konsulko.com>2020-08-28 17:37:48 -0400
commit9e0287f2780776cfd171311de7dd86213d7319fa (patch)
tree7e4acb60e8ddcc2e68dbf18cf69e4d1accb1a87f /setup.py
parent1032040e56ac7dfa8ad4b2b929614b04ff6190e4 (diff)
Add license file and copyrights
Add Apache 2.0 license text as LICENSE file, and copyright headers to all source files. Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py15
1 files changed, 15 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 7b9b97d..7d8b53d 100644
--- a/setup.py
+++ b/setup.py
@@ -1,3 +1,18 @@
+# Copyright (C) 2020 Konsulko Group
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
import setuptools
with open("README.md", "r") as fh: