aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 92178e2..ad7faf2 100644
--- a/setup.py
+++ b/setup.py
@@ -16,13 +16,13 @@ with io.open(os.path.join(root, "snips_inference_agl", "__about__.py"),
required = [
"deprecation>=2.0,<3.0",
"future>=0.16,<0.18",
- "numpy>=1.22.0,<1.22.4",
+ "numpy>=1.26.4",
"num2words>=0.5.6,<0.6",
"pyaml>=17.0,<20.0",
"requests>=2.0,<3.0",
- "scipy>=1.8.0,<1.9.0",
+ "scipy>=1.14.0",
"threadpoolctl>=2.0.0",
- "scikit-learn==0.24.2",
+ "scikit-learn>=1.4.2",
"sklearn-crfsuite>=0.3.6,<0.4",
"snips-nlu-parsers>=0.4.3,<0.4.4",
"snips-nlu-utils>=0.9.1,<0.9.2",