aboutsummaryrefslogtreecommitdiffstats
path: root/chardev/meson.build
diff options
context:
space:
mode:
authorTimos Ampelikiotis <t.ampelikiotis@virtualopensystems.com>2023-10-10 11:40:56 +0000
committerTimos Ampelikiotis <t.ampelikiotis@virtualopensystems.com>2023-10-10 11:40:56 +0000
commite02cda008591317b1625707ff8e115a4841aa889 (patch)
treeaee302e3cf8b59ec2d32ec481be3d1afddfc8968 /chardev/meson.build
parentcc668e6b7e0ffd8c9d130513d12053cf5eda1d3b (diff)
Introduce Virtio-loopback epsilon release:
Epsilon release introduces a new compatibility layer which make virtio-loopback design to work with QEMU and rust-vmm vhost-user backend without require any changes. Signed-off-by: Timos Ampelikiotis <t.ampelikiotis@virtualopensystems.com> Change-Id: I52e57563e08a7d0bdc002f8e928ee61ba0c53dd9
Diffstat (limited to 'chardev/meson.build')
-rw-r--r--chardev/meson.build44
1 files changed, 44 insertions, 0 deletions
diff --git a/chardev/meson.build b/chardev/meson.build
new file mode 100644
index 000000000..325ba2bdb
--- /dev/null
+++ b/chardev/meson.build
@@ -0,0 +1,44 @@
+chardev_ss.add(files(
+ 'char-fe.c',
+ 'char-file.c',
+ 'char-io.c',
+ 'char-mux.c',
+ 'char-null.c',
+ 'char-pipe.c',
+ 'char-ringbuf.c',
+ 'char-serial.c',
+ 'char-socket.c',
+ 'char-stdio.c',
+ 'char-udp.c',
+ 'char.c',
+))
+chardev_ss.add(when: 'CONFIG_POSIX', if_true: files(
+ 'char-fd.c',
+ 'char-parallel.c',
+ 'char-pty.c',
+))
+chardev_ss.add(when: 'CONFIG_WIN32', if_true: files(
+ 'char-console.c',
+ 'char-win-stdio.c',
+ 'char-win.c',
+))
+
+chardev_ss = chardev_ss.apply(config_host, strict: false)
+
+softmmu_ss.add(files('msmouse.c', 'wctablet.c', 'testdev.c'))
+
+chardev_modules = {}
+
+if brlapi.found()
+ module_ss = ss.source_set()
+ module_ss.add(when: [brlapi], if_true: [files('baum.c'), pixman])
+ chardev_modules += { 'baum': module_ss }
+endif
+
+if spice.found()
+ module_ss = ss.source_set()
+ module_ss.add(when: [spice], if_true: files('spice.c'))
+ chardev_modules += { 'spice': module_ss }
+endif
+
+modules += { 'chardev': chardev_modules }