aboutsummaryrefslogtreecommitdiffstats
path: root/hw/sh4/meson.build
diff options
context:
space:
mode:
authorTimos Ampelikiotis <t.ampelikiotis@virtualopensystems.com>2023-10-10 11:40:56 +0000
committerTimos Ampelikiotis <t.ampelikiotis@virtualopensystems.com>2023-10-10 11:40:56 +0000
commite02cda008591317b1625707ff8e115a4841aa889 (patch)
treeaee302e3cf8b59ec2d32ec481be3d1afddfc8968 /hw/sh4/meson.build
parentcc668e6b7e0ffd8c9d130513d12053cf5eda1d3b (diff)
Introduce Virtio-loopback epsilon release:
Epsilon release introduces a new compatibility layer which make virtio-loopback design to work with QEMU and rust-vmm vhost-user backend without require any changes. Signed-off-by: Timos Ampelikiotis <t.ampelikiotis@virtualopensystems.com> Change-Id: I52e57563e08a7d0bdc002f8e928ee61ba0c53dd9
Diffstat (limited to 'hw/sh4/meson.build')
-rw-r--r--hw/sh4/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/hw/sh4/meson.build b/hw/sh4/meson.build
new file mode 100644
index 000000000..424d5674d
--- /dev/null
+++ b/hw/sh4/meson.build
@@ -0,0 +1,9 @@
+sh4_ss = ss.source_set()
+sh4_ss.add(files(
+ 'sh7750.c',
+ 'sh7750_regnames.c',
+))
+sh4_ss.add(when: 'CONFIG_R2D', if_true: files('r2d.c'))
+sh4_ss.add(when: 'CONFIG_SHIX', if_true: files('shix.c'))
+
+hw_arch += {'sh4': sh4_ss}