aboutsummaryrefslogtreecommitdiffstats
path: root/meson/test cases/common/144 link depends custom target/meson.build
diff options
context:
space:
mode:
authorAngelos Mouzakitis <a.mouzakitis@virtualopensystems.com>2023-10-10 14:33:42 +0000
committerAngelos Mouzakitis <a.mouzakitis@virtualopensystems.com>2023-10-10 14:33:42 +0000
commitaf1a266670d040d2f4083ff309d732d648afba2a (patch)
tree2fc46203448ddcc6f81546d379abfaeb323575e9 /meson/test cases/common/144 link depends custom target/meson.build
parente02cda008591317b1625707ff8e115a4841aa889 (diff)
Add submodule dependency filesHEADmaster
Change-Id: Iaf8d18082d3991dec7c0ebbea540f092188eb4ec
Diffstat (limited to 'meson/test cases/common/144 link depends custom target/meson.build')
-rw-r--r--meson/test cases/common/144 link depends custom target/meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/meson/test cases/common/144 link depends custom target/meson.build b/meson/test cases/common/144 link depends custom target/meson.build
new file mode 100644
index 000000000..ee7a865d9
--- /dev/null
+++ b/meson/test cases/common/144 link depends custom target/meson.build
@@ -0,0 +1,19 @@
+project('link_depends_custom_target', 'c')
+
+if meson.backend().startswith('vs')
+ # FIXME: Broken on the VS backends
+ error('MESON_SKIP_TEST see https://github.com/mesonbuild/meson/issues/1799')
+endif
+
+cmd = find_program('make_file.py')
+
+dep_file = custom_target('gen_dep',
+ command: [cmd, '@OUTPUT@'],
+ output: 'dep_file')
+
+exe = executable('foo', 'foo.c',
+ link_depends: dep_file,
+ c_args: ['-DDEPFILE="' + dep_file.full_path()+ '"'])
+
+# check that dep_file exists, which means that link_depends target ran
+test('runtest', exe)